class ElementSelectFilterSetting

class NemAll_Python_IFW_Input.ElementSelectFilterSetting

Settings class to control the object selection

Clear() None

Reset the settings

GetLayerSelectType() eLayerSnoopType

Get the layer selection type

Returns:

Return the layer selection type

IsBaseClassType(typeID: GUID) bool

Check, whether the element type is a base class type

Args:

typeID:  Element type ID

Returns:

Element type is a base class type: true/false

IsClear() bool

Get the clear state

Returns:

true, if the members contain default values

IsPointSelect() bool

Get the point select state

Returns:

Point selection is active: true/false

IsSelectPassiveInfoElement() bool

Get the selection state of a passive info element

Returns:

Allow to select passive info element if no active element was found: true/false

SelectPassiveInfoElement() None

Allow to select passive info element if no active element was found

SetArchitectureFilterQuery(positive: bool = True]) None

Set a prefabricated filter for all architecture elements

Args:

positive:  if the filter will true for architecture elements otherwise the filter will be false for architecture elements

SetAssoFilterQuery(positive: bool = True]) None

Set a prefabricated filter for all associative view elements

Args:

positive:  if the filter will true for associative view elements otherwise the filter will be false for associative view elements

SetDocumentLayerFilter(bSnoopAllElements: bool) None

Set the document and layer filter

Args:

bSnoopAllElements:  Snoop all elements: true/false

SetDocumentSelectType(documentSnoopType: eDocumentSnoopType) None

Set the selection mode for the document (active, passive or all documents)

Args:

documentSnoopType:  Selection mode for the document (active, passive or all documents)

SetLayerSelectType(layerSnoopType: eLayerSnoopType) None

Set the layer selection type

Args:

layerSnoopType:  Type of the allowed layers for the selection

SetPointSelect() None

Set the point select state

__init__(...)
__init__() None
__init__(bSnoopAllElements: bool) None

Constructor

default values: Query is empty

Args:

bSnoopAllElements:  true = snoop all elements, false = snoop active elements

__init__(filter: SelectionQuery, bSnoopAllElements: bool) None

Constructor

default value for eObjectSelectType == SEL_ALL

Args:

filter:             Filter for the type of the object to search for
bSnoopAllElements:  true = snoop all elements, false = snoop active elements

__init__(filter: SelectionQuery, documentSnoopType: eDocumentSnoopType, layerSnoopType]: eLayerSnoopType) None

Constructor

default value for eObjectSelectType == SEL_ALL

Args:

filter:             Filter for the type of the object to search for
documentSnoopType:  Selection mode for the document (active, passive or all documents)
layerSnoopType:     Selection mode for the layer (active, passive or all layers)

__init__(selectSetting: ElementSelectFilterSetting) None

Copy Constructor

Args:

selectSetting:  Copy this ElementSelectFilterSetting

property LayerSelectType: eLayerSnoopType

Get the layer selection type

Set the layer selection type

__module__ = 'NemAll_Python_IFW_Input'

class NemAll_Python_IFW_Input.eLayerSnoopType

Definition of the layer snoop types

__module__ = 'NemAll_Python_IFW_Input'
eSnoopActiveLayers = NemAll_Python_IFW_Input.eLayerSnoopType.eSnoopActiveLayers
eSnoopActiveLayersMsg = NemAll_Python_IFW_Input.eLayerSnoopType.eSnoopActiveLayersMsg
eSnoopAllLayers = NemAll_Python_IFW_Input.eLayerSnoopType.eSnoopAllLayers
eSnoopPassiveLayers = NemAll_Python_IFW_Input.eLayerSnoopType.eSnoopPassiveLayers
eSnoopPassiveLayersOrDocs = NemAll_Python_IFW_Input.eLayerSnoopType.eSnoopPassiveLayersOrDocs

class NemAll_Python_IFW_Input.eDocumentSnoopType

Definition of the document snoop types

__module__ = 'NemAll_Python_IFW_Input'
eSnoopActiveDocuments = NemAll_Python_IFW_Input.eDocumentSnoopType.eSnoopActiveDocuments
eSnoopAllDocuments = NemAll_Python_IFW_Input.eDocumentSnoopType.eSnoopAllDocuments
eSnoopPassiveDocsOrLayers = NemAll_Python_IFW_Input.eDocumentSnoopType.eSnoopPassiveDocsOrLayers
eSnoopPassiveDocuments = NemAll_Python_IFW_Input.eDocumentSnoopType.eSnoopPassiveDocuments