class QueryTypeID

class NemAll_Python_IFW_Input.QueryTypeID

Implementation of the element type ID query

GetQueryText() str

Get the query text

Returns:

Query text

GetQueryTypeID() GUID

Get the ID of the type query

Returns:

ID of the type query

__call__(ele: BaseElementAdapter) bool

Overloaded operator ()

Args:

ele:  Element to check

Returns:

Type of the element is same as the filter type: true/false

__init__(...)
__init__() None
__init__(typeID: GUID) None

Constructor

Args:

typeID:  Element type ID of the filter

__init__(element: QueryTypeID) None

Copy constructor

Args:

element:  Element to copy

__repr__() str

Convert to string

__module__ = 'NemAll_Python_IFW_Input'