class SelectionQuery¶
- class NemAll_Python_IFW_Input.SelectionQuery¶
Implementation of the selection query
- Clear() None ¶
Clear the query
- IsEmpty() bool ¶
Check for an empty query
- Returns:
Filter is empty: true/false
- __init__(...)¶
- __init__() None ¶
- __init__(query: SelectionQuery) None ¶
Copy constructor
- Args:
query:  Query to copy
- __init__(query: object) object ¶
Constructor
- Args:
query:  Selection query as list with queries or single query.
        The queries can be a QueryTypeID or a class with a __call__ member
- __module__ = 'NemAll_Python_IFW_Input'¶