Global settings

The class AllplanGlobalSettings gives access to the current Allplan settings like pen, stroke, color, …

class NemAll_Python_AllplanSettings.AllplanGlobalSettings

Helper class for global Allplan settings exposure

GetCurrentColorId() int

Get the current used color ID in Allplan

Returns:

Current color ID

GetCurrentCommonProperties() CommonProperties

Get the current common properties

Returns:

Current common properties

GetCurrentFaceStyleId() int

Get the current used face style ID in Allplan

Returns:

Current face style ID

GetCurrentFontId() int

Get the current used font ID in Allplan

Returns:

Current font ID

GetCurrentHatchId() int

Get the current used hatch ID in Allplan

Returns:

Current hatch ID

GetCurrentLayerId() int

Get the current used layer ID in Allplan

Returns:

Current layer ID

GetCurrentPatternId() int

Get the current used pattern ID in Allplan

Returns:

Current pattern ID

GetCurrentPenId() int

Get the current used pen ID in Allplan

Returns:

Current pen ID

GetCurrentStrokeId() int

Get the current used stroke ID in Allplan

Returns:

Current stroke ID

GetOffsetPoint() Point3D

Get the offset point

Returns:

Offset point

__init__()

This class cannot be instantiated from Python

__module__ = 'NemAll_Python_AllplanSettings'