Common properties¶
The class CommonProperties can be used to set and get the common properties like pen, stroke, color, … of the elements.
- class NemAll_Python_BaseElements.CommonProperties¶
Implementation of the common properties of the element
- GetColorPenStrokeByLayerFromLayerNumber(layernumber: int) VecIntList ¶
Layer number
- Returns:
[0] = pen,[1] = stroke, [2] color
- GetGlobalProperties() None ¶
Get the global properties
- __eq__(props: CommonProperties) object ¶
Compare operator
- Args:
props:  Properties to compare
- Returns:
Properties a equal: true/false
- __init__(...)¶
- __init__() None ¶
- __init__(element: CommonProperties) None ¶
Copy constructor
- Args:
element:  Element to copy
- __repr__() str ¶
Convert to string
- property Activated: bool¶
Get the activated state
Set the activated flag
- property Color: int¶
Get the color
Set the color
- property ColorByLayer: bool¶
Get the color by layer state
Set the color by layer flag
- property ConstructionLine: bool¶
Get the construction line state
Set the construction line mode
- property DrawOrder: int¶
Get the drawOrder
Set the drawOrder
- property ForceColor: bool¶
Get flag if force color is set
Set flag - force color to graphic engine
- property HelpConstruction: bool¶
Get flag if pen and stroke is help construction
Set flag - is help construction
- property InSpecialWindow: bool¶
Get the special window visibility
Set the special window visibility flag
- property Layer: int¶
Get the layer
Set the layer
- property Marked: bool¶
Get the marked state
Set the marked flag
- property PageNumber: int¶
Get the page number
Set the page number
- property Pen: int¶
Get the pen
Set the pen
- property PenByLayer: bool¶
Get the pen by layer state
Set the pen by layer flag
- property Printable: bool¶
Get the printable state
Set the printable mode
- property Stroke: int¶
Get the stroke
Set the stroke
- property StrokeByLayer: bool¶
Get the stroke by layer state
Set the stroke by layer flag
- property Visible: bool¶
Get the visible flag state
Set the visibility
- property VisibleInsideZoomwindows: bool¶
Get the visible inside zoom window state
Set the visible inside zoom windows flag
- property VisibleOutsideZoomwindows: bool¶
Get the visible outside zoom window state
Set the visible outside zoom windows flag
- __module__ = 'NemAll_Python_BaseElements'¶