Preview settings

By default, the preview for the PythonPart is optimized for performance. For this reason, the isometric curves of the BReps are not drawn. This can be disabled/enabled by

  • typing alt+V

  • calling the function PythonPartsSettings.GetInstance().SetShowFullPreview(True)

class NemAll_Python_AllplanSettings.PythonPartsSettings

Implementation of the PythonParts settings

GetInstance() PythonPartsSettings

Get the instance

Returns:

Instance of the singleton

SetLengthUnit(lengthUnit: int) None

Set the length unit

Args:

lengthUnit:  Length unit: 3 = m

SetShowFullPreview(showFullPreview: bool) None

Show the full preview

Args:

showFullPreview:  Show full preview: true/false

__init__()

This class cannot be instantiated from Python

property IsShowFullPreview: bool

Get the full preview state

Show the full preview

__module__ = 'NemAll_Python_AllplanSettings'