Skip to content

Allplan Global Settings

Class full path: NemAll_Python_AllplanSettings.AllplanGlobalSettings

Helper class for global Allplan settings exposure

Functions

GetCurrentColorId() staticmethod

Get the current used color ID in Allplan

Returns:

Type Description
int

Current color ID

GetCurrentCommonProperties() staticmethod

Get the current common properties

Returns:

Type Description
CommonProperties

Current common properties

GetCurrentFaceStyleId() staticmethod

Get the current used face style ID in Allplan

Returns:

Type Description
int

Current face style ID

GetCurrentFontId() staticmethod

Get the current used font ID in Allplan

Returns:

Type Description
int

Current font ID

GetCurrentHatchId() staticmethod

Get the current used hatch ID in Allplan

Returns:

Type Description
int

Current hatch ID

GetCurrentLayerId() staticmethod

Get the current used layer ID in Allplan

Returns:

Type Description
int

Current layer ID

GetCurrentPatternId() staticmethod

Get the current used pattern ID in Allplan

Returns:

Type Description
int

Current pattern ID

GetCurrentPenId() staticmethod

Get the current used pen ID in Allplan

Returns:

Type Description
int

Current pen ID

GetCurrentStrokeId() staticmethod

Get the current used stroke ID in Allplan

Returns:

Type Description
int

Current stroke ID

GetOffsetPoint() staticmethod

Get the offset point

Returns:

Type Description
Point3D

Offset point