Skip to content

Bending Shape

Class full path: NemAll_Python_Reinforcement.BendingShape

Implementation of the reinforcement shape

Attributes

BendingRoller: list[float] property writable

Get the bending roller

HookLengthEnd: float property writable

Get the hook length a the end of the shape

HookLengthStart: float property writable

Get the hook length a the start of the shape

ShapePolyline: NemAll_Python_Geometry.Polyline3D property writable

Get the shape polyline

Functions

GetBendingRoller()

Get the bending roller

Returns:

Type Description
VecDoubleList

Bending roller

GetBendingShapeType()

Get the bending shape type

GetConcreteGrade()

Get the concrete grade

Returns:

Type Description
int

Concrete grade (index of the global list starting from 0, -1 = use global value from the Allplan settings)

GetDiameter()

Get the diameter

Returns:

Type Description
float

Diameter

GetHookAngleEnd()

Get the hook angle a the end of the shape

Returns:

Type Description
float

Hook angle at the end of the shape

GetHookAngleStart()

Get the hook angle a the start of the shape

Returns:

Type Description
float

Hook angle at the start of the shape

GetHookLengthEnd()

Get the hook length a the end of the shape

Returns:

Type Description
float

Hook length at the end of the shape

GetHookLengthStart()

Get the hook length a the start of the shape

Returns:

Type Description
float

Hook length at the start of the shape

GetHookTypeEnd()

Get the hook type a the end of the shape

GetHookTypeStart()

Get the hook type a the start of the shape

GetMeshBendingDirection()

Get the mesh bending direction

Returns:

Type Description
MeshBendingDirection

Mesh bending direction

GetMeshType()

Get the mesh type

GetShapePolyline()

Get the shape polyline

Returns:

Type Description
Polyline3D

Shape polyline

GetSteelGrade()

Get the steel grade

Returns:

Type Description
int

Steel grade

IsValid()

Get the state of the shape

Returns:

Type Description
bool

Shape is valid: true/false

Move(transVec)

Move the shape

Parameters:

Name Type Description Default
transVec Vector3D

Move vector

required

Rotate overload

Rotate(modelAngles, refPnt)

Rotate the shape

Parameters:

Name Type Description Default
modelAngles object

Model angles

required
refPnt Point3D

Reference point of the rotation

required
Rotate(modelAngles)

Rotate the shape

Parameters:

Name Type Description Default
modelAngles object

Model angles

required

SetBendingRoller(bendingRoller)

Set the bending roller

Parameters:

Name Type Description Default
bendingRoller VecDoubleList

Bending roller

required

SetHookLengthEnd(hookLengthEnd)

Set the end length of the hook

Parameters:

Name Type Description Default
hookLengthEnd float

End length of the hook

required

SetHookLengthStart(hookLengthStart)

Set the start length of the hook

Parameters:

Name Type Description Default
hookLengthStart float

Start length of the hook

required

SetShapePolyline(shapePol)

Set the shape polyline

Parameters:

Name Type Description Default
shapePol Polyline3D

Shape polyline

required

Transform(transMat)

Transform the shape

Parameters:

Name Type Description Default
transMat Matrix3D

Transformation matrix

required

__eq__(shape)

Compare operator

Parameters:

Name Type Description Default
shape BendingShape

Shape to compare

required

Returns:

Type Description
bool

Shapes are equal: true/false

__init__ overload

__init__()

Initialize

__init__(shapePol, bendingRoller, diameter, steelGrade, concreteGrade, bendingShapeType)

Constructor

Parameters:

Name Type Description Default
shapePol Polyline3D

Shape polyline

required
bendingRoller VecDoubleList

Bending roller

required
diameter float

Diameter

required
steelGrade int

Steel grade

required
concreteGrade int

Concrete grade (index of the global list starting from 0, -1 = use global value from the Allplan settings)

required
bendingShapeType BendingShapeType

Bending shape type

required
__init__(shapePoint, diameter, steelGrade, concreteGrade)

Constructor for a point placement

Parameters:

Name Type Description Default
shapePoint Point3D

Shape placement point

required
diameter float

Diameter

required
steelGrade int

Steel grade

required
concreteGrade int

Concrete grade (index of the global list starting from 0, -1 = use global value from the Allplan settings)

required
__init__(shapePol, bendingRoller, meshType, meshBendingDirection, steelGrade, concreteGrade, bendingShapeType)

Constructor

Parameters:

Name Type Description Default
shapePol Polyline3D

Shape polyline

required
bendingRoller VecDoubleList

Bending roller

required
meshType str

Mesh type

required
meshBendingDirection MeshBendingDirection

Mesh bending direction

required
steelGrade int

Steel grade

required
concreteGrade int

Concrete grade (index of the global list starting from 0, -1 = use global value from the Allplan settings)

required
bendingShapeType BendingShapeType

Bending shape type

required
__init__(shapePol, bendingRoller, diameter, steelGrade, concreteGrade, bendingShapeType, hookLengthStart, hookAngleStart, hookTypeStart, hookLengthEnd, hookAngleEnd, hookTypeEnd)

Constructor

Parameters:

Name Type Description Default
shapePol Polyline3D

Shape polyline

required
bendingRoller VecDoubleList

Bending roller

required
diameter float

Diameter

required
steelGrade int

Steel grade

required
concreteGrade int

Concrete grade (index of the global list starting from 0, -1 = use global value from the Allplan settings)

required
bendingShapeType BendingShapeType

Bending shape type

required
hookLengthStart float

Hook length at the start of the shape

required
hookAngleStart float

Hook angle at the start of the shape

required
hookTypeStart HookType

Hook type at the start of the shape

required
hookLengthEnd float

Hook length at the end of the shape

required
hookAngleEnd float

Hook angle at the end of the shape

required
hookTypeEnd HookType

Hook type at the end of the shape

required
__init__(shapePol, bendingRoller, meshType, meshBendingDirection, steelGrade, concreteGrade, bendingShapeType, hookLengthStart, hookAngleStart, hookTypeStart, hookLengthEnd, hookAngleEnd, hookTypeEnd)

Constructor

Parameters:

Name Type Description Default
shapePol Polyline3D

Shape polyline

required
bendingRoller VecDoubleList

Bending roller

required
meshType str

Mesh type

required
meshBendingDirection MeshBendingDirection

Mesh bending direction

required
steelGrade int

Steel grade

required
concreteGrade int

Concrete grade (index of the global list starting from 0, -1 = use global value from the Allplan settings)

required
bendingShapeType BendingShapeType

Bending shape type

required
hookLengthStart float

Hook length at the start of the shape

required
hookAngleStart float

Hook angle at the start of the shape

required
hookTypeStart HookType

Hook type at the start of the shape

required
hookLengthEnd float

Hook length at the end of the shape

required
hookAngleEnd float

Hook angle at the end of the shape

required
hookTypeEnd HookType

Hook type at the end of the shape

required
__init__(element)

Copy constructor

Parameters:

Name Type Description Default
element BendingShape

Element to copy

required

__repr__()

Convert to string