Skip to content

Reinforcement Service

Class full path: NemAll_Python_Reinforcement.ReinforcementService

Reinforcement service

Classes

BarShapeCodeStandard

Bases: IntEnum

Standard for the bar shape code

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
BarShapeCodeStandard

value for the key

Functions

GetACIBarMark(barsDefinitionElement, showIndex) staticmethod

Get the bar mark

Parameters:

Name Type Description Default
barsDefinitionElement BaseElementAdapter

Bars definition element

required
showIndex bool

Show the index

required

Returns:

Type Description
list

bar mark for ACI

GetACIPlacementBarMark(barsPlacementElement, showIndex) staticmethod

Get the bar mark for a placement

Parameters:

Name Type Description Default
barsPlacementElement BaseElementAdapter

Bars placement element

required
showIndex bool

Show the index

required

Returns:

Type Description
tuple

tuple(bar mark for ACI, bar count)

GetBarPositionData(elementVec) staticmethod

Get the bar position data

Parameters:

Name Type Description Default
elementVec BaseElementAdapterList

GUID vector with the elements

required

Returns:

Type Description
list

List with the bar position data

GetBarShapeCode(barsDefinitionElement) staticmethod

Get the bar shape code

Parameters:

Name Type Description Default
barsDefinitionElement BarShapeCodeStandard

Bars definition element

required
barShapeCopdeStandard

Standard for the bar shape code

required

Returns:

Type Description
tuple

shape code count, list of (shape codes, bar length), list of (segment name, segment lengths)) for ACI

tuple

shape code count, list of shape codes, list of lengths) for all other