Skip to content

Export Import Service

Class full path: NemAll_Python_BaseElements.ExportImportService

Implementation of the export/import service

Functions

ExportDWG(doc, fileName, configFileName, version)

Export the data to a DWG file by a configuration file

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required
fileName str

Name of the DWG file

required
configFileName str

Name of the DWG configuration file

required
version int

Version numer

required

ExportDWGByTheme(doc, fileName, themeFileName, version=2018)

Export the data to a DWG file by a theme file

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required
fileName str

Name of the DWG file

required
themeFileName str

Name of the DWG theme file

required
version int

DWG version

2018

ExportIFC(doc, fileNumbers, ifcVersion, fileName, ifcThemeFileName='')

Export the data to an IFC file

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required
fileNumbers [list[int] | VecIntList]

Numbers of the drawing files to export

required
ifcVersion IFC_Version

IFC version

required
fileName str

Name of the IFC file

required
ifcThemeFileName str

Name of the theme file

''

ExportXPlan(doc, fileNumbers, xplanFilePath)

Export the data to a XPlan file

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required
fileNumbers [list[int] | VecIntList]

Numbers of the drawing files to export

required
xplanFilePath str

Path and name of the XPlan file

required

ImportDWG(doc, fileName, configFileName, placePnt)

Import the data from a DWG file

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required
fileName str

Name of the DWG file

required
configFileName str

Name of the DWG configuration file

required
placePnt Point3D

Placement point of the data

required

ImportIFC(doc, fileNumber, fileName)

Import the data from an IFC file

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required
fileNumber int

Number of the drawing file for the data import

required
fileName str

Name of the IFC file

required

Returns:

Type Description
BaseElementAdapterList

List with the imported elements

ImportXPlan(doc, xplanFilePath, drawingFileNumber)

Import the data from a XPlan file

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required
xplanFilePath str

Path and name of the XPlan file to import

required
drawingFileNumber int

Starting number of destination drawing file(s)

required

__init__ overload

__init__()

Initialize

__init__(element)

Copy constructor

Parameters:

Name Type Description Default
element ExportImportService

Element to copy

required