Skip to content

Section Definition Properties

Class full path: NemAll_Python_BasisElements.SectionDefinitionProperties

Section definition properties

Attributes

ClippingPathProperties: None property

Set/Get the clipping path properties

:type: None

IsAdvancedOn: None property

Property for type of section architecture= OFF /Engineering = ON

:type: None

IsSectionBodyOn: None property

Property for show the section body

:type: None

RefMode: None property

Property for the reference mode

:type: None

ViewInputType: None property

Property for the view input type

:type: None

Classes

RefMode_Enum

Bases: IntEnum

View input type

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
RefMode_Enum

value for the key

ViewInputType_Enum

Bases: IntEnum

View input type

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
ViewInputType_Enum

value for the key

Functions

__init__()

Initialize