Skip to content

Clothoid2D

Class full path: NemAll_Python_Geometry.Clothoid2D

2D clothoid Representation class for 2D clothoid.

Attributes

EndCurvature: None property

Get and set the end curvature property

:type: None

EndPoint: None property

Get and set the end point property

:type: None

IsReversed: None property

Get and set the reversed property

:type: None

Length: None property

Get and set the length property

:type: None

Parallel: None property

Get and set the parallel property

:type: None

RefPoint: None property

Get and set the end point property

:type: None

StartCurvature: None property

Get and set the start curvature property

:type: None

StartPoint: None property

Get and set the start point property

:type: None

StartVector: None property

Get and set the start vector property

:type: None

Type: None property

Get and set the type property

:type: None

Functions

GetEndCurvature()

Get end curvature.

Returns:

Type Description
float

double end curvature of clothoid.

GetEndPoint()

Get end point in world coordinate system.

Returns:

Type Description
Point2D

point Point2D.

GetEndRelPoint()

Get the end point in relative coordinate system

Returns:

Type Description
Point2D

constant reference to Point2D.

GetIsReversed()

is clothoid reversed

Returns:

Type Description
bool

true/false

GetLength()

Get length of clothoid.

Returns:

Type Description
float

double length of clothoid.

GetParallel()

Get parallel of clothoid.

Returns:

Type Description
float

double parallel of clothoid.

GetRefPoint()

Get reference point in world coordinate system

Returns:

Type Description
Point2D

reference to point.

GetStartCurvature()

Get start curvature.

Returns:

Type Description
float

double start curvature of clothoid.

GetStartPoint()

Get start point in world coordinate system.

Returns:

Type Description
Point2D

point Point2D.

GetStartRelPoint()

Get the start point in relative coordinate system

Returns:

Type Description
Point2D

constant reference to Point2D.

GetStartVector()

Get start vector.

Returns:

Type Description
Vector2D

const reference to Vector2D.

GetType()

Get type of clothoid.

Reverse()

Reverse orientation of the Clothoid

Set(clothoid)

Initialize clothoid from clothoid.

Parameters:

Name Type Description Default
clothoid Clothoid2D

Clothoid2D.

required

SetEndCurvature(curvature)

Set end curvature of clothoid.

Parameters:

Name Type Description Default
curvature float

end curvature of clothoid

required

SetEndPoint(point)

Set end point in world coordinate system.

Parameters:

Name Type Description Default
point Point2D

const reference to Point2D in World coordinate system.

required

SetEndRelPoint(point)

Set end point in local coordinate system

Parameters:

Name Type Description Default
point Point2D

Point2D in local coordinate system

required

SetLength(length)

Set length of clothoid.

Parameters:

Name Type Description Default
length float

length of clothoid.

required

SetParallel(parallel)

Set parallel of clothoid.

Parameters:

Name Type Description Default
parallel float

length of clothoid.

required

SetRefPoint(refPoint)

Set reference point in world coordinate system

Parameters:

Name Type Description Default
refPoint Point2D

const reference to Point2D in World coordinate system.

required

SetReversed(flag)

Set orientation.

Parameters:

Name Type Description Default
flag bool

true for reversed, false normal orientation.

required

SetStartCurvature(curvature)

Set start curvature of clothoid.

Parameters:

Name Type Description Default
curvature float

start curvature of clothoid

required

SetStartPoint(point)

Set start point in world coordinate system.

Parameters:

Name Type Description Default
point Point2D

const reference to Point2D in World coordinate system.

required

SetStartRelPoint(point)

Set start point in local coordinate system

Parameters:

Name Type Description Default
point Point2D

Point2D in local coordinate system

required

SetStartVector(vec)

Set start vector.

Parameters:

Name Type Description Default
vec Vector2D

const reference to Vector2D.

required

SetType(type)

Set type of clothoid.

Parameters:

Name Type Description Default
type eClothoidType

type of clothoid.

required

__eq__(clothoid)

Comparison of clothoids without tolerance.

Be careful, this method work without tolerance!

Parameters:

Name Type Description Default
clothoid Clothoid2D

Compared clothoid.

required

Returns:

Type Description
object

True when clothoids are equal, otherwise false.

__init__ overload

__init__()

Initialize

__init__(clothoid)

Copy constructor.

Parameters:

Name Type Description Default
clothoid Clothoid2D

Clothoid2D which will be copied.

required

__mul__(matrix)

Matrix transformation.

Parameters:

Name Type Description Default
matrix Matrix2D

transformation matrix.

required

Returns:

Type Description
object

Clothoid2D transformed clothoid.

__repr__()

Convert the list to a string

Returns:

Type Description
str

List values as string