Skip to content

Bar Area Placement Service

Class full path: NemAll_Python_Reinforcement.BarAreaPlacementService

Functions

AddOpeningPolygon(arg2, openingPol)

Add an opening polygon

Parameters:

Name Type Description Default
openingPol float

Opening polygon

required

Calculate(doc, barPlacementProp, placementMatrix, concreteCoverZDir)

Calculate the meshes

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required
barPlacementProp BarAreaPlacementProperties

Placement properties

required
placementMatrix Matrix3D

Placement matrix

required
concreteCoverZDir float

Concrete cover in the local z direction

required

SetOuterPolygon(arg2, placementPol)

Constructor

Parameters:

Name Type Description Default
placementPol float

Placement polygon

required

__init__()

Initialize