Skip to content

Python Wpf Palette

Class full path: NemAll_Python_Palette.PythonWpfPalette

Functions

Close()

Close the palette

EnableControl(arg2, name, bEnabled)

Enable/disable a control

Parameters:

Name Type Description Default
name int

Name of the control

required
bEnabled bool

Enabled: true/false

required

GetPythonWpfPaletteBuilder()

Get the palette builder

Returns:

Type Description
PythonWpfPaletteBuilder

Palette builder

Open(arg2, title, partName, dataColumnWidth, showCloseButton, doc)

Open the palette

Parameters:

Name Type Description Default
title str

Title

required
partName int

Name of the PythonPart

required
dataColumnWidth bool

Width of the data column

required
showCloseButton DocumentAdapter

Show the close button

required
doc str

Document

required

Reset(clearOnlyPages)

Reset the palette for a full refresh

Parameters:

Name Type Description Default
clearOnlyPages bool

Reset only pages, keep other dialog data settings

required

UpdateDialogData(arg2)

Refresh palette with current dialog data

__init__()

Constructor

__repr__()

Convert the list to a string

Returns:

Type Description
str

List values as string