Skip to content

Face Select Service

Class full path: NemAll_Python_BaseElements.FaceSelectService

Functions

SelectPolyhedronFace(polyhedron, pnt, highlightFace, viewProj, doc, includeUVSSelection) staticmethod

Select a polyhedron face

Parameters:

Name Type Description Default
polyhedron BaseElementAdapter

Polyhedron

required
pnt Point2D

Selection view point

required
highlightFace bool

Highlight the face state

required
viewProj ViewWorldProjection

View world projection of the selected view

required
doc DocumentAdapter

Document

required
includeUVSSelection bool

Include an UVS selection for the face

required

Returns:

Type Description
tuple[bool, Polygon3D, IntersectionRayPolyhedron]

select state, face polygon, intersection result

SelectPolyhedronFaceInUVS(polyhedron, pnt, highlightFace, viewProj, doc) staticmethod

Select a polyhedron face in an UVS

Parameters:

Name Type Description Default
polyhedron BaseElementAdapter

Polyhedron

required
pnt Point2D

Selection view point

required
highlightFace bool

Highlight the face state

required
viewProj ViewWorldProjection

View world projection of the selected view

required
doc DocumentAdapter

Document

required

Returns:

Type Description
tuple[bool, Polygon3D, IntersectionRayPolyhedron, Matrix3D]

select state, face polygon, intersection result, UVS matrix

SelectWallFace(wallTier, pnt, highlightFace, viewProj, doc, includeUVSSelection) staticmethod

Select a wall face

Parameters:

Name Type Description Default
wallTier BaseElementAdapter

Wall tier

required
pnt Point2D

Selection view point

required
highlightFace bool

Highlight the face state

required
viewProj ViewWorldProjection

View world projection of the selected view

required
doc DocumentAdapter

Document

required
includeUVSSelection bool

Include an UVS selection for the face

required

Returns:

Type Description
tuple[bool, Polygon3D, IntersectionRayPolyhedron]

select state, face polygon, intersection result

SelectWallFaceInUVS(wallTier, pnt, highlightFace, viewProj, doc) staticmethod

Select a wall face in an UVS

Parameters:

Name Type Description Default
wallTier BaseElementAdapter

Wall tier

required
pnt Point2D

Selection view point

required
highlightFace bool

Highlight the face state

required
viewProj ViewWorldProjection

View world projection of the selected view

required
doc DocumentAdapter

Document

required

Returns:

Type Description
tuple[bool, Polygon3D, IntersectionRayPolyhedron, Matrix3D]

select state, face polygon, intersection result, UVS matrix