Skip to content

Reinforcement Type

Class full path: NemAll_Python_Reinforcement.ReinforcementType

Bases: IntEnum

Types of the reinforcement

Attributes

Bar = 0 class-attribute instance-attribute

Mesh = 1 class-attribute instance-attribute

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
ReinforcementType

value for the key