Skip to content

Reinforcement Label

Class full path: NemAll_Python_Reinforcement.ReinforcementLabel

Functions

SetAdditionalText(additionalText)

Set the additional text

Parameters:

Name Type Description Default
additionalText str

Additional text

required

SetLabelOffset(labelOffset)

Set the label offset

Parameters:

Name Type Description Default
labelOffset Vector2D

Label offset

required

SetPointerStartPoint(pointerStartPoint)

Set the start pointer of the text pointer

Parameters:

Name Type Description Default
pointerStartPoint Point2D

Start point of the text pointer

required

SetShowTextPointer(showTextPointer)

Set the state for showing the text pointer

Parameters:

Name Type Description Default
showTextPointer bool

Show the text pointer: true/false

required

SetShowTextPointerEndSymbol(showTextPointerEndSymbol)

Set the state for showing the text pointer end symbol

Parameters:

Name Type Description Default
showTextPointerEndSymbol bool

Show the text pointer end symbol: true/false

required

SetTextProperties(textProperties)

Set the text properties

Parameters:

Name Type Description Default
textProperties TextProperties

Text properties

required

SetVisibleBars(visibleBars)

Set the vector with the visible bars

Parameters:

Name Type Description Default
visibleBars [list[int] | VecIntList]

Vector with the visible bars: 1, 2, 3, .. index from left; -1, -2, -3, ... index from right, 0 = center

required

ShowAllBars(bShowAllBars)

Set the all bars inside the dimension line, ... state

Parameters:

Name Type Description Default
bShowAllBars bool

Show all bars in the dimension lines, ...: true/false

required

__init__ overload

__init__()

Initialize

__init__(reinforcementType, type, positionNumber, labelProp, labelPoint, angle)

Constructor

Parameters:

Name Type Description Default
reinforcementType ReinforcementType

Reinforcement type

required
type LabelType

Label type

required
positionNumber int

Position number

required
labelProp ReinforcementLabelProperties

Label properties

required
labelPoint Point2D

Label placement point

required
angle Angle

Angle

required
__init__(reinforcementType, type, positionNumber, labelProp, shapeSide, shapeSideFactor, labelOffset, angle)

Constructor

Parameters:

Name Type Description Default
reinforcementType ReinforcementType

Reinforcement type

required
type LabelType

Label type

required
positionNumber int

Position number

required
labelProp ReinforcementLabelProperties

Label properties

required
shapeSide int

Shape side for the text pointer

required
shapeSideFactor float

Factor for the text pointer at the shape side

required
labelOffset Vector2D

Label offset

required
angle Angle

Angle

required
__init__(reinforcementType, type, positionNumber, labelProp, bDimLineAtShapeStart, dimLineOffset)

Constructor

Parameters:

Name Type Description Default
reinforcementType ReinforcementType

Reinforcement type

required
type LabelType

Label type

required
positionNumber int

Position number

required
labelProp ReinforcementLabelProperties

Label properties

required
bDimLineAtShapeStart bool

Placement of the dimension line: at shape start = true / at shape end = false

required
dimLineOffset float

Offset of the dimension line from the placement

required
__init__(reinforcementType, type, positionNumber, labelProp, pointerProp, bDimLineAtShapeStart, dimLineOffset)

Constructor

Parameters:

Name Type Description Default
reinforcementType ReinforcementType

Reinforcement type

required
type LabelType

Label type

required
positionNumber int

Position number

required
labelProp ReinforcementLabelProperties

Label properties

required
pointerProp ReinforcementLabelPointerProperties

Pointer properties

required
bDimLineAtShapeStart bool

Placement of the dimension line: at shape start = true / at shape end = false

required
dimLineOffset float

Offset of the dimension line from the placement

required