Skip to content

Elements Select Service

Class full path: NemAll_Python_BaseElements.ElementsSelectService

Functions

SelectAllElements(ele) staticmethod

Select all elements from the document

Parameters:

Name Type Description Default
doc

Document

required

Returns:

Type Description
BaseElementAdapterList

All elements from the document

SelectElementsByIfcGuid(ele) staticmethod

Select elements by IFC guids

Parameters:

Name Type Description Default
doc

Document

required
ifcGuids

List with the IFC GUIDs

required

Returns:

Type Description
BaseElementAdapterList

Elements