Skip to content

Longitudinal Bar Properties

Class full path: NemAll_Python_Reinforcement.LongitudinalBarProperties

Implementation of the longitudinal bar properties

Attributes

BendingShape: BendingShape property writable

Get the bending shape

Classes

eDeliveryShapeType

Bases: IntEnum

Delivery shape types

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
eDeliveryShapeType

value for the key

eInsideBarsState

Bases: IntEnum

Inside bar state

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
eInsideBarsState

value for the key

Functions

GetBendingShape()

Get the bending shape

Returns:

Type Description
BendingShape

Bending shape

GetDeliveryShapeType()

Get the delivery shape type

GetInsideBarsState()

Get the insid bars state

Returns:

Type Description
eInsideBarsState

Inside bars state

GetMinBarDistance()

Get the minimal bar distance

Returns:

Type Description
float

Minimal bar distance

GetOverlappingAtEnd()

Get the overlapping at end

Returns:

Type Description
float

Overlapping at end

GetOverlappingAtStart()

Get the overlapping at start

Returns:

Type Description
float

Overlapping at start

GetOverlappingLength()

Get the overlapping length

Returns:

Type Description
float

Overlapping length

GetStartLength()

Get the start length

Returns:

Type Description
float

Start length

IsOverlappingAtEndTurnedOn()

Get the overlapping at end state

Returns:

Type Description
bool

Overlapping at end state

IsOverlappingAtStartTurnedOn()

Get the overlapping at start state

Returns:

Type Description
bool

Overlapping at start state

SetBendingShape(shape)

Set the bending shape

Parameters:

Name Type Description Default
shape BendingShape

Shape

required

Returns:

Type Description

Bending shape

__eq__(LongitudinalBarProperties)

Compare operator

Args:

Returns:

Type Description
bool

Bars are equal: true/false

__init__ overload

__init__()

Initialize

__init__(shape, overlappingAtStartTurnedOn, overlappingAtStart, overlappingAtEndTurnedOn, overlappingAtEnd, overlappingLength, minBarDistance, deliveryShapeType, insideBarsState, startLength)

Constructor

Parameters:

Name Type Description Default
shape BendingShape

Bar shape

required
overlappingAtStartTurnedOn bool

Overlapping at start start

required
overlappingAtStart float

Overlapping at start

required
overlappingAtEndTurnedOn bool

Overlapping at end state

required
overlappingAtEnd float

Overlapping at end

required
overlappingLength float

Overlapping length

required
minBarDistance float

Minimal bar distance

required
deliveryShapeType eDeliveryShapeType

Delivery shape type

required
insideBarsState eInsideBarsState

Inside bars state

required
startLength float

Start length

required