Skip to content

e Approximation Settings Type

Class full path: NemAll_Python_Geometry.eApproximationSettingsType

Bases: IntEnum

Type of Approximation setting

Used for identification of Approximation settings type.

Attributes

ASET_BREP_TESSELATION = 3 class-attribute instance-attribute

ASET_MAX_DISTANCE = 2 class-attribute instance-attribute

ASET_MAX_LENGTH = 1 class-attribute instance-attribute

ASET_SEGMENTATION = 0 class-attribute instance-attribute

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
eApproximationSettingsType

value for the key