Skip to content

Symbol2D Properties

Class full path: NemAll_Python_BasisElements.Symbol2DProperties

Symbol2DProperties class

Attributes

Height: None property

Property for height

:type: None

IsScaleDependent: None property

Property for scale dependency

:type: None

PrimaryPointNumber: None property

Property for primary point number

:type: None

RotationAngle: None property

Property for rotation angle

:type: None

SecondaryPointNumber: None property

Property for secondary point number

:type: None

SymbolID: None property

Property for symbol ID

:type: None

Width: None property

Property for width

:type: None

Functions

__eq__(prop)

equal operator

Parameters:

Name Type Description Default
prop Symbol2DProperties

Symbol2DProperties to compare

required

Returns:

Type Description
bool

true if they are equal, false otherwise

__init__()

Initialize

__repr__()

Convert the list to a string

Returns:

Type Description
str

List values as string