Skip to content

Common Properties

Class full path: NemAll_Python_BaseElements.CommonProperties

Implementation of the common properties of the element

Attributes

Activated: bool property writable

Get the activated state

Color: int property writable

Get the color

ColorByLayer: bool property writable

Get the color by layer state

ConstructionLine: bool property writable

Get the construction line state

DrawOrder: int property writable

Get the drawOrder

ForceColor: bool property writable

Get flag if force color is set

HelpConstruction: bool property writable

Get flag if pen and stroke is help construction

InSpecialWindow: bool property writable

Get the special window visibility

Layer: int property writable

Get the layer

Marked: bool property writable

Get the marked state

PageNumber: int property writable

Get the page number

Pen: int property writable

Get the pen

PenByLayer: bool property writable

Get the pen by layer state

Printable: bool property writable

Get the printable state

Stroke: int property writable

Get the stroke

StrokeByLayer: bool property writable

Get the stroke by layer state

Visible: bool property writable

Get the visible flag state

VisibleInsideZoomwindows: bool property writable

Get the visible inside zoom window state

VisibleOutsideZoomwindows: bool property writable

Get the visible outside zoom window state

Functions

GetColorPenStrokeByLayerFromLayerNumber(layernumber) staticmethod

Layer number

Returns:

Type Description
[list[int] | VecIntList]

[0] = pen,[1] = stroke, [2] color

GetGlobalProperties()

Get the global properties

__eq__(props)

Compare operator

Parameters:

Name Type Description Default
props CommonProperties

Properties to compare

required

Returns:

Type Description
object

Properties a equal: true/false

__init__ overload

__init__()

Initialize

__init__(element)

Copy constructor

Parameters:

Name Type Description Default
element CommonProperties

Element to copy

required

__repr__()

Convert to string