Skip to content

Attributes

Class full path: NemAll_Python_BaseElements.Attributes

Attributes class

Attributes

AttributeSets: None property

Property for attribute set vector

:type: None

Functions

GetAttributeSets()

Get the AttributeSet vector

Returns:

Type Description
list

Attribute value

SetAttributeSets(sets)

Set the AttributeSet vector

Parameters:

Name Type Description Default
sets list

AttributeSet vector

required

__eq__(props)

Compare operator

Parameters:

Name Type Description Default
props Attributes

Properties to compare

required

Returns:

Type Description
bool

Properties a equal: true/false

__init__ overload

__init__()

Initialize

__init__(elements)

Constructor

Parameters:

Name Type Description Default
elements list

Attribute set element list

required

__repr__()

Convert the list to a string

Returns:

Type Description
str

List values as string