Skip to content

Label Type

Class full path: NemAll_Python_BasisElements.LabelType

Bases: IntEnum

Type of the label

Attributes

eLabelArchDimensionLine = 3 class-attribute instance-attribute

eLabelBftSlabElementation = 5 class-attribute instance-attribute

eLabelBftWallElementation = 4 class-attribute instance-attribute

eLabelEng3DBarReinforcement = 2 class-attribute instance-attribute

eLabelNoText = 7 class-attribute instance-attribute

eLabelNormalText = 0 class-attribute instance-attribute

eLabelVariableText = 1 class-attribute instance-attribute

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
LabelType

value for the key