Skip to content

Text Element

Class full path: NemAll_Python_BasisElements.TextElement

Bases: BasisElement, AllplanElement

Implementation of the Text element

Attributes

Text: str property writable

Get the text string

TextProperties: TextProperties property writable

Get the Text properties

Functions

GetDimensions(arg2)

Get the text size

Returns:

Type Description
Vector2D

Text size

Parameters:

Name Type Description Default
doc

Document

required

GetText()

Get the text string

Returns:

Type Description
str

Text string

GetTextPoints(arg2, arg3)

Get the text points

Returns:

Type Description
Point2DList

List with the text points

Point2DList

Point2DList

|3 6 2|

Point2DList

| |

Point2DList

|7 5|

Point2DList

| |

Point2DList

|0__4____1|

Parameters:

Name Type Description Default
doc

Document

required
refPnt

Reference point of the text

required

GetTextProperties()

Get the Text properties

Returns:

Type Description
TextProperties

Text properties

SetText(text)

Set the text string

Parameters:

Name Type Description Default
text str

Text string

required

SetTextProperties(textProp)

Set the Text properties

Parameters:

Name Type Description Default
textProp TextProperties

Text properties

required

__eq__(textEle)

Comparison operator

Parameters:

Name Type Description Default
textEle TextElement

Text element to compare

required

Returns:

Type Description
bool

Comparison state

__init__ overload

__init__()

Initialize

__init__(commonProp, textProp, text, textPnt)

Constructor

Parameters:

Name Type Description Default
commonProp CommonProperties

Common properties

required
textProp TextProperties

Text properties

required
text str

Text string

required
textPnt Point2D

Text point

required
__init__(element)

Copy constructor

Parameters:

Name Type Description Default
element TextElement

Element to copy

required

__repr__()

Convert to string