Skip to content

Allplan Element

Class full path: NemAll_Python_Precast.AllplanElement

Implementation of the Allplan element

Attributes

Attributes: object property writable

Get the attributes object

CommonProperties: NemAll_Python_BaseElements.CommonProperties property writable

Get the common properties

GeometryObject: object property writable

Get the geometry object

LabelElements: list property writable

Get the label elements

Functions

GetAttributes()

Get the attributes object

Returns:

Type Description
object

Attributes object

GetCommonProperties()

Get the common properties

Returns:

Type Description
CommonProperties

Common properties

GetGeometryObject()

Get the geometry object

Returns:

Type Description
object

Geometry object

GetLabelElements()

Get the label elements

Returns:

Type Description
list

LabelElements

GetSubElementID()

Get the sub element ID

Returns:

Type Description
type

Sub Element ID

SetAttributes(attributeContainer)

Set the attributes object

Parameters:

Name Type Description Default
attributeContainer object

Attributes object

required

SetCommonProperties(commonProp)

Set the common properties

Parameters:

Name Type Description Default
commonProp CommonProperties

Common properties

required

SetDockingPointsKey(dockingPointsKey)

Set the docking points key

Parameters:

Name Type Description Default
dockingPointsKey str

Docking points key

required

SetGeometryObject(geoObject)

Set the geometry object

Parameters:

Name Type Description Default
geoObject object

Geometry object

required

SetLabelElements(labelElements)

Set the label elements

Parameters:

Name Type Description Default
labelElements list

Label elements

required