Skip to content

e Projection Type

Class full path: NemAll_Python_IFW_Input.eProjectionType

Bases: IntEnum

Projection type of the view

Attributes

EAST_VIEW = 3 class-attribute instance-attribute

FREE_ONLY_3D = 9 class-attribute instance-attribute

FREE_VIEW = 0 class-attribute instance-attribute

GROUND_PLAN = 1 class-attribute instance-attribute

NORTH_EAST_VIEW = 5 class-attribute instance-attribute

NORTH_VIEW = 2 class-attribute instance-attribute

NORTH_WEST_VIEW = 6 class-attribute instance-attribute

SOUTH_EAST_VIEW = 8 class-attribute instance-attribute

SOUTH_VIEW = -2 class-attribute instance-attribute

SOUTH_WEST_VIEW = 7 class-attribute instance-attribute

WEST_VIEW = -3 class-attribute instance-attribute

WORKING_PLANE_VIEW = 4 class-attribute instance-attribute

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
eProjectionType

value for the key