Skip to content

Associative View Properties

Class full path: NemAll_Python_BasisElements.AssociativeViewProperties

Attributes

AdjacentEdges: None property

Set/get the adjacent edges state

:type: None

ColorHiddenEdge: None property

Set/get the color of the hidden edges

:type: None

ColorVisibleEdge: None property

Set/get the color of the visible edges

:type: None

ConvertTo2D: None property

Set/get the convert to 2D state

:type: None

ElementRepresentation: None property

Set/get the element representation

:type: None

Hidden: None property

Set/get the hidden state

:type: None

LayerBoundaryLine: None property

Set/get the layer of the boundary line

:type: None

LayerFinishLine: None property

Set/get the layer of the finish line

:type: None

LayerHiddenEdge: None property

Set/get the layer of the hidden edges

:type: None

LayerHiddenSectionLine: None property

Set/get the layer of the hidden section line

:type: None

LayerSectionLine: None property

Set/get the layer of the section line

:type: None

LayerVisibleEdge: None property

Set/get the layer of the visible edges

:type: None

PenHiddenEdge: None property

Set/get the pen of the hidden edges

:type: None

PenVisibleEdge: None property

Set/get the pen of the visible edges

:type: None

RemoveAdjacentEdges: None property

Set/get the remove adjacent edges state

:type: None

ShowHiddenEdges: None property

Set/get the show hidden edges state

:type: None

ShowSectionBody: None property

:type: None

ShowVisibleEdges: None property

Set/get the show visible edges state

:type: None

StrokeHiddenEdge: None property

Set/get the stroke of the hidden edges

:type: None

StrokeVisibleEdge: None property

Set/get the stroke of the visible edges

:type: None

Functions

__init__ overload

__init__()

Initialize

__init__(arg2)

Constructor

__init__(arg2)

Constructor