Skip to content

Snoop Element Geometry Filter

Class full path: NemAll_Python_IFW_Input.SnoopElementGeometryFilter

Functions

AddElements(arg2)

__init__ overload

__init__()

Initialize

__init__(bFindBaseGeometry, bFindAreaGeometry, bPerpendicularOnElement, bFindNonPassiveOnly, bSplitAreaGeometries, bIdentifyEmbeddedElement, bFindCompleteFootprint, splitElement3D)

Constructor

Passive geometry is virtual geometry which is using for element snooping. Typical passive geometry is boundary area around text. This area has no edges like a Hatching, but if cursor is inside this area, then element must be snooped. Passive geometry has no points, perpendicular points, edges, etc. .

Parameters:

Name Type Description Default
bFindBaseGeometry bool

If true, find the base geometry element (e.g. line from polyline)

required
bFindAreaGeometry bool

If true, the service adds the nearest area geometry if nothing else is found

required
bPerpendicularOnElement bool

If true, the service adds perpendicular geometry

required
bFindNonPassiveOnly bool

If true, then only non passive geometry will be searching

required
bSplitAreaGeometries bool

If true, find the line geometry element for area geometries (e.g line from polygon)

required
bIdentifyEmbeddedElement bool

If true, find elements from embedded documents

required
bFindCompleteFootprint bool

If true, find the complete footprint of a wall instead of the footprint of the wall tier

required
splitElement3D eSplitElement3D

Split the 3D element geometry ---> in case of bFindBaseGeometry the split is always done to edges !!!

required