Skip to content

Face Offset

Class full path: NemAll_Python_Geometry.FaceOffset

Face offset

Classes

eFaceOffsetDirection

Bases: IntEnum

Face offset direction

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
eFaceOffsetDirection

value for the key

Functions

IsResultBrep()

returns if selected object has brep geometry

Returns:

Type Description
bool

true if brep

Offset(offsetDistance, direction, useOffsetStepPierce, useOrthoVXSplit, punchDirection)

Execute face offset

Parameters:

Name Type Description Default
offsetDistance float

distance for offset

required
direction eFaceOffsetDirection

offset direction 0 - in face normal direction, 1 - in both directions, 2 - opposite to face normal

required
useOffsetStepPierce bool

if to use offset step pierce

required
useOrthoVXSplit bool

if to use OrthoVXSplit option

required
punchDirection Vector3D

defined direction for offset (optional)

required

Returns:

Type Description
tuple

eOK if success,

tuple

first resulting geometry,

tuple

second resulting geometry, set only if offset in both direction is performed

Shell(offsetDistance, direction, useOffsetStepPierce, useOrthoVXSplit, punchDirection)

Execute face shell

Parameters:

Name Type Description Default
offsetDistance float

distance for offset

required
direction eFaceOffsetDirection

offset direction 0 - in face normal direction, 1 - in both directions, 2 - opposite to face normal

required
useOffsetStepPierce bool

if to use offset step pierce

required
useOrthoVXSplit bool

if to use OrthoVXSplit option

required
punchDirection Vector3D

defined direction for shell (optional)

required

Returns:

Type Description
tuple

eOK if success,

tuple

resulting geometry

__init__ overload

__init__(inputPolyhedron)

Constructor with polyhedron input geometry

Parameters:

Name Type Description Default
inputPolyhedron Polyhedron3D

polyhedron to execute face offset/shell on

required
__init__(inputPolyhedron, faceIndices)

Constructor with polyhedron element

Parameters:

Name Type Description Default
inputPolyhedron Polyhedron3D

polyhedron to execute face offset/shell on

required
faceIndices VecSizeTList

vector of indices of faces to offset/shell

required
__init__(inputBRep)

Constructor with brep element

Parameters:

Name Type Description Default
inputBRep BRep3D

brep to execute face offset/shell on

required
__init__(inputBRep, faceIndices)

Constructor with brep element

Parameters:

Name Type Description Default
inputBRep BRep3D

brep to execute face offset/shell on

required
faceIndices VecSizeTList

vector of indices of faces for offset/shell

required