Skip to content

Base Element Adapter Child Elements Service

Class full path: NemAll_Python_IFW_ElementAdapter.BaseElementAdapterChildElementsService

Functions

GetChildModelElements(ele, hidden=False) staticmethod

Get the child model elements of the element

Parameters:

Name Type Description Default
ele BaseElementAdapter

Element

required
hiddenElements

Include the hidden elements

required

Returns:

Type Description
BaseElementAdapterList

Child elements of the element

GetChildModelElementsFromTree(ele) staticmethod

Get the child model elements from the complete child tree of the element

Parameters:

Name Type Description Default
ele BaseElementAdapter

Element

required

Returns:

Type Description
BaseElementAdapterList

Child model elements from the complete child tree of the element

GetTierElements(ele) staticmethod

Get the tier elements from an element

Parameters:

Name Type Description Default
ele BaseElementAdapter

Element

required

Returns:

Type Description
BaseElementAdapterVector

Tier elements