Skip to content

LCS_ Flags

Class full path: NemAll_Python_IFW_Input.LCS_Flags

Bases: IntEnum

eStandard: standard coordinate system symbol eSmall : small coordinate system symbol eHoverX : the x arrow will be black eHoverY : the y arrow will be black eHoverZ : the z arrow will be black

Attributes

eHoverX = 2 class-attribute instance-attribute

eHoverY = 4 class-attribute instance-attribute

eHoverZ = 8 class-attribute instance-attribute

eSmall = 1 class-attribute instance-attribute

eStandard = 0 class-attribute instance-attribute

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
LCS_Flags

value for the key