Skip to content

Reference Plane ID

Class full path: NemAll_Python_ArchElements.ReferencePlaneID

struct for handling reference plane IDs

Attributes

ModelGuid: None property

model ID

:type: None

PlaneId: None property

plane ID

:type: None

Functions

ChangeModel(inputModelGuid)

change model id to another

Parameters:

Name Type Description Default
inputModelGuid GUID
required

Invalidate()

Set values to undefined state

IsDefaultLowerPlane()

Find out if reference plane is default lower reference plane

Returns:

Type Description
bool

true if ref plane is default lower ref plane

IsDefaultUpperPlane()

Find out if reference plane is default upper reference plane

Returns:

Type Description
bool

true if ref plane is default upper ref plane

IsDocumentRefSurface()

Find out if reference surface is from document

Returns:

Type Description
bool

true is reference surface from document (not in model)

IsInModel()

Find out if refrence plane is in model

Returns:

Type Description
bool

true if ref plane is in model

IsValid()

Get validity of ref plane

Returns:

Type Description
bool

true if ref plane is valid

SetCustomLowerPlane()

Set values to custom lower state

SetCustomUpperPlane()

Set values to custom upper state

__eq__(other)

Args: other:

__init__ overload

__init__()

Initialize

__init__(modelGuid, planeId)

Constructor

Parameters:

Name Type Description Default
modelGuid GUID
required
planeId int
required
__init__(element)

Copy constructor

Parameters:

Name Type Description Default
element ReferencePlaneID

Element to copy

required

__lt__(other)

Args: other:

__ne__(other)

Args: other:

__repr__()

Convert to string