Skip to content

Fixture Placement Properties

Class full path: NemAll_Python_Precast.FixturePlacementProperties

FixturePlacementProperties class

Attributes

Automation: None property

Property for automation

:type: None

ConnectionToAIACatalog: None property

Property for connection to AIACatalog

:type: None

ConnectionToAllplanCatalog: None property

Property for connection to AllplanCatalog

:type: None

CountOfQuestions: None property

Property for count of questions

:type: None

DistortionState: None property

Property for distortion state

:type: None

DomainType: None property

Property for domain type

:type: None

EnableQuestions: None property

Property for enable questions

:type: None

HasParentModificationBehaviour: None property

Property for specific behavior for modification state

:type: None

HeightDefinitionType: None property

Property for height definition types

:type: None

HollowShaft: None property

Property for hollow shaft

:type: None

Mass_V6: None property

Property for V6 attribute

:type: None

Mass_V7: None property

Property for V7 attribute

:type: None

Mass_V8: None property

Property for V8 attribute

:type: None

Mass_V9: None property

Property for V9 attribute

:type: None

Matrix: None property

Property for matrix. Specifies location in world coordinate system

:type: None

MirrorState: None property

Property for the fixture placement mirrored state

:type: None

Name: None property

Property for name

:type: None

OutlineShape: None property

Property for outline shape

:type: None

OutlineType: None property

Property for outline type

:type: None

OutlineTypeInGroup: None property

Property for outline type in group

:type: None

PositionNr: None property

Property for position number

:type: None

ProfilType: None property

Property for profil type

:type: None

SubType: None property

Property for sub type

:type: None

Type: None property

Property for type

:type: None

UnitFactor: None property

Property for unit factor

:type: None

UseAlways2DRepInGroundView: None property

Property for state if always 2D representation in ground view is shown

:type: None

UseDrawOrder: None property

Property for the draw order setting of the placement or the elements of the fixture

:type: None

UseFormat: None property

Property for the format setting (pen, stroke, color) of the placement or the elements of the macro

:type: None

Visibility: None property

Property for visibility

:type: None

Functions

__eq__(prop)

equal operator

Parameters:

Name Type Description Default
prop FixturePlacementProperties

FixturePlacementProperties to compare

required

Returns:

Type Description
bool

true if they are equal, false otherwise

__init__()

Initialize

__repr__()

Convert the list to a string

Returns:

Type Description
str

List values as string