Skip to content

Stirrup Type

Class full path: NemAll_Python_Reinforcement.StirrupType

Bases: IntEnum

Types of the stirrups

Attributes

Column = 3 class-attribute instance-attribute

Diamond = 4 class-attribute instance-attribute

FullCircle = 5 class-attribute instance-attribute

Normal = 1 class-attribute instance-attribute

Torsion = 2 class-attribute instance-attribute

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
StirrupType

value for the key