Skip to content

Plane References

Class full path: NemAll_Python_ArchElements.PlaneReferences

Bases: BasePlaneReferences

Implementation of the plane references

Attributes

AdaptTopLevelToPlane: int property writable

Get the top level to plane adaption

BottomElevation: float property writable

Get the bottom plane elevation

Direction: int property writable

Get the direction

Document: NemAll_Python_IFW_ElementAdapter.DocumentAdapter property writable

Get the document

LowerPlane: ReferencePlaneID property writable

Get the lower plane

MaxHeight: float property writable

Get the maximal height

ReferenceElement: NemAll_Python_IFW_ElementAdapter.BaseElementAdapter property writable

Get the reference element for the plane

TopElevation: float property writable

Get the top plane elevation

UpperPlane: ReferencePlaneID property writable

Get the upper plane

Classes

PlaneReferenceDependency

Bases: IntEnum

Plane reference Dependency

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
PlaneReferenceDependency

value for the key

Functions

GetAbsBottomElevation()

Get the absolute bottom elevation

Returns:

Type Description
float

Absolute bottom elevation

GetAbsTopElevation()

Get the absolute top elevation

Returns:

Type Description
float

Absolute top elevation

GetBottomElevation()

Get the bottom plane elevation

Returns:

Type Description
float

Bottom plane elevation

GetBottomPlaneDependency()

Get the bottom plane dependency

Returns:

Type Description
PlaneReferenceDependency

Bottom plane dependency

GetDocument()

Get the document

Returns:

Type Description
DocumentAdapter

Document

GetReferenceElement()

Get the reference element for the plane

GetTopElevation()

Get the top plane elevation

Returns:

Type Description
float

Top plane elevation

GetTopPlaneDependency()

Get the top plane dependency

Returns:

Type Description
PlaneReferenceDependency

Top plane dependency

SetBottomElevation(elevation)

Set the bottom plane elevation

Parameters:

Name Type Description Default
elevation float

Elevation

required

SetBottomPlaneDependency(dependency)

Set the bottom plane dependency

Parameters:

Name Type Description Default
dependency PlaneReferenceDependency

Dependency

required

SetBottomToBottom(planeRef)

Set the bottom level to the bottom level of the source plane reference

Parameters:

Name Type Description Default
planeRef PlaneReferences

Source plane reference

required

SetBottomToTop(planeRef)

Set the bottom level to the top level of the source plane reference

Parameters:

Name Type Description Default
planeRef PlaneReferences

Source plane reference

required

SetDocument(doc)

Set the document

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required

SetReferenceElement(refElement)

Set the reference element for the plane

Parameters:

Name Type Description Default
refElement BaseElementAdapter

Reference element

required

SetTopElevation(elevation)

Set the top plane elevation

Parameters:

Name Type Description Default
elevation float

Elevation

required

SetTopPlaneDependency(dependency)

Set the top plane dependency

Parameters:

Name Type Description Default
dependency PlaneReferenceDependency

Dependency

required

SetTopToBottom(planeRef)

Set the top level to the bottom level of the source plane reference

Parameters:

Name Type Description Default
planeRef PlaneReferences

Source plane reference

required

SetTopToTop(planeRef)

Set the top level to the top level of the source plane reference

Parameters:

Name Type Description Default
planeRef PlaneReferences

Source plane reference

required

__init__ overload

__init__(doc, refElement)

Constructor

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required
refElement BaseElementAdapter

Reference element for the plane (if current exist)

required
__init__(element)

Copy constructor

Parameters:

Name Type Description Default
element PlaneReferences

Element to copy

required

__repr__()

Convert to string