Skip to content

Project Service

Class full path: NemAll_Python_BaseElements.ProjectService

Functions

CloseAllplan() staticmethod

Close Allplan

GetCurrentProjectNameAndHost() staticmethod

Get the project and host name

Returns:

Type Description
tuple

tuple(project name, host name)

GetCurrentUserAsBwsPath() staticmethod

Get the current user as BWS path

Returns:

Type Description
str

User as BWS path

GetProjectPath(projectName, hostName) staticmethod

Get the project path

Parameters:

Name Type Description Default
hostName str

Host name

required
projectName str

Project name

required

Returns:

Type Description
tuple

tuple(Error, project path)

OpenProject(hostName, projectName, doc) staticmethod

Open the project

Parameters:

Name Type Description Default
doc str

Document

required
hostName DocumentAdapter

Host name

required
projectName str

Project name

required

Returns:

Type Description
str

Active project

str

Project not exist

str

Not possible to open the project

str

Project opened