Skip to content

Bar Shape Side Data List

Class full path: StdReinfShapeBuilder.BarShapeSideDataList.BarShapeSideDataList

Bases: List[Union[float, Tuple[Point2D, Point2D, float], Tuple[Point2D, Point2D, float, float], Tuple[Point2D, Point2D, float, float, float], Tuple[Line2D, float], Tuple[Line2D, float, float], Tuple[Line2D, float, float, float], Tuple[Arc2D, float, float, float], Tuple[Point3D, Point3D, float], Tuple[Point3D, Point3D, float, float], Tuple[Line3D, float], Tuple[Line3D, float, float]]]

the rows can have the following tuple entries

cover: float as concrete cover at the start/end of the shape

or

(start point: AllplanGeo.Point2D as start point of the side, end point: AllplanGeo.Point2D as end point of the side, cover: float as concrete cover of the side, bending_roller: float as optional bending roller at the side end, z_coord_bar: float as optional bar coordinate in z direction of the local shape coordinate system)

or

(start point: AllplanGeo.Point3D as start point of the side, end point: AllplanGeo.Point3D as end point of the side, cover: float as concrete cover of the side, bending_roller: float as optional bending roller at the side end)

or

(line: AllplanGeo.Line2D/3D as side, cover: float as concrete cover of the side, bending_roller: float as optional bending roller at the side end)

or

(arc: AllplanGeo.Arc2D as side, cover: float as concrete cover of the side, bending_roller: float as optional bending roller at the side end)