Skip to content

Section Along Path Elevation Specifications

Class full path: NemAll_Python_BasisElements.SectionAlongPathElevationSpecifications

Elevation specifications

Attributes

DecimalPlaces: int property writable

Get the number of places after decimal point

FontHeight: float property writable

Get the Height of the character set

FontNameStrg: str property writable

Get the Name the the character set

HeightWidthFactor: float property writable

Get the height/width ratio

IsAbsoluteElevation: bool property writable

Get the Absolute elevation

IsDimensionLineVisible: bool property writable

Get the visibility of dimension line

IsDimensionNumberVisible: bool property writable

Get the Dimension number is visible

IsFixFraction: bool property writable

Get the Fix fraction

IsFontBold: bool property writable

Get the character set Bold

IsFontItalic: bool property writable

Get the character set Italic

IsFontUnderline: bool property writable

Get the character set Underline

IsFreeElevation: bool property writable

Get the Free elevation

IsLineColorFromLayer: bool property writable

Get the settings from layers three checkboxes on third page in layer dialog like in BBasisDimSettings.h (do not know, why is it is doubled)

IsLineColorSameForAll: bool property writable

Get the the same line color for DMline,auxiliary line and number/texts

IsLineColorTake: bool property writable

Get the settings from layers three checkboxes on third page in layer dialog

IsModifiedIsTextOpaque: bool property writable

Get the is text opaque

IsPenFromLayer: bool property writable

Get the settings from layers three checkboxes on third page in layer dialog like in BasisDimSettings.h (do not know, why is it is doubled)

IsPenSameForAll: bool property writable

Get the the same pen for DMline,auxiliary line and number/texts

IsPenSymbolFlag: bool property writable

Get the when true -> pen for symbol as help construction line

IsPenTake: bool property writable

Get the settings from layers three checkboxes on third page in layer dialog

IsPlusMinusSign: bool property writable

Get the Draw +- sign before zero number

IsPositiveSign: bool property writable

Get the Draw +s ign before positive number

IsTextSymbolFlag: bool property writable

Get the when true -> pen for text as help construction line

LayerId: int property writable

Get the Layer Number

LeadingCharacters: str property writable

Get the prefix of dimension number/additional number(16)

MeasuredValueUnit: int property writable

Get the Unit of the measured value

PointSymbol: int property writable

Get the Point symbol

PointSymbolSize: float property writable

Get the symbol size in mm/inch

RoundOffInch: float property writable

Get the round of number inch units

RoundOffNormal: float property writable

Get the round of number metric units

SymbolColorId: int property writable

Get the Symbol color

SymbolPenId: int property writable

Get the Symbol pen

TailingCharacters: str property writable

Get the suffix of dimension number/additional number(16)

TailingZeros: int property writable

Get the number of zeros after decimal point

TextColorId: int property writable

Get the Text color

TextLocation: int property writable

Get the text location from position / location of texts (up to enum eTextLocation)

TextOffset: float property writable

Get the distance -> offset of texts from dimension line

TextPenId: int property writable

Get the Text pen

Functions

__init__ overload

__init__(bInitFromSTW=False)

constructor

Parameters:

Name Type Description Default
bInitFromSTW bool
  • is structure initialized from standard values
False
__init__(B)

copy constructor

Parameters:

Name Type Description Default
B SectionAlongPathElevationSpecifications
  • object to copy
required