Skip to content

e Document Snoop Type

Class full path: NemAll_Python_IFW_Input.eDocumentSnoopType

Bases: IntEnum

Definition of the document snoop types

Attributes

eSnoopActiveDocuments = 0 class-attribute instance-attribute

eSnoopAllDocuments = 2 class-attribute instance-attribute

eSnoopPassiveDocsOrLayers = 3 class-attribute instance-attribute

eSnoopPassiveDocuments = 1 class-attribute instance-attribute

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
eDocumentSnoopType

value for the key