Skip to content

Bottom Top Plane Service

Class full path: NemAll_Python_ArchElements.BottomTopPlaneService

Implementation of the bottom top plane service

Functions

GetAbsoluteBottomElevation(refElement, doc, planeProp) staticmethod

Get the absolute elevation of the bottom plane

Parameters:

Name Type Description Default
refElement BaseElementAdapter

Reference element (empty element if not exist)

required
doc DocumentAdapter

Document

required
planeProp BasePlaneReferences

Plane properties

required

Returns:

Type Description
float

Absolute elevation of the bottom plane

GetAbsoluteTopElevation(refElement, doc, planeProp) staticmethod

Get the absolute elevation of the top plane

Parameters:

Name Type Description Default
refElement BaseElementAdapter

Reference element (empty element if not exist)

required
doc DocumentAdapter

Document

required
planeProp BasePlaneReferences

Plane properties

required

Returns:

Type Description
float

Absolute elevation of the top plane

GetBottomReferencePlane(refElement, doc, planeProp) staticmethod

Get the bottom reference plane

Parameters:

Name Type Description Default
refElement BaseElementAdapter

Reference element (empty element if not exist)

required
doc DocumentAdapter

Document

required
planeProp BasePlaneReferences

Plane properties

required

Returns:

Type Description
Union[BRep3D, Polyhedron3D, Plane3D]

Bottom reference plane as Plan3D, BRep3D or Polyhedron3D

GetDocumentDefaultPlanes(doc) staticmethod

Get the default bottom and top plane of the document

Parameters:

Name Type Description Default
doc DocumentAdapter
required

Returns:

Type Description
tuple[Plane3D, Plane3D]

Default bottom and top plane of the document

GetTopReferencePlane(refElement, doc, planeProp) staticmethod

Get the top reference plane

Parameters:

Name Type Description Default
refElement BaseElementAdapter

Reference element (empty element if not exist)

required
doc DocumentAdapter

Document

required
planeProp BasePlaneReferences

Plane properties

required

Returns:

Type Description
Union[BRep3D, Polyhedron3D, Plane3D]

Bottom reference plane as Plan3D, BRep3D or Polyhedron3D