Skip to content

Project Attribute Service

Class full path: NemAll_Python_BaseElements.ProjectAttributeService

Implementation of the project attribute service

Functions

ChangeAttributeFromCurrentProject overload

ChangeAttributeFromCurrentProject(attributeNumber, newValue, doc) staticmethod

Change a project attribute from the current file

Parameters:

Name Type Description Default
attributeNumber int

Attribute number

required
newValue int

Attribute value

required
doc DocumentAdapter

Document

required
ChangeAttributeFromCurrentProject(attributeNumber, newValue, doc) staticmethod

Change a project attribute from the current file

Parameters:

Name Type Description Default
attributeNumber int

Attribute number

required
newValue float

Attribute value

required
doc DocumentAdapter

Document

required
ChangeAttributeFromCurrentProject(attributeNumber, newValue, doc) staticmethod

Change a project attribute from the current file

Parameters:

Name Type Description Default
attributeNumber int

Attribute number

required
newValue str

Attribute value

required
doc DocumentAdapter

Document

required

ChangeAttributesFromCurrentProject(attributes, doc) staticmethod

Change attributes from the current project

Parameters:

Name Type Description Default
attributes list[tuple[int, Union[int, float, str]]]

Attributes

required
doc DocumentAdapter

Document

required

GetAttributesFromAllProjects() staticmethod

Get the attributes from all projects

Returns:

Type Description
list[tuple[int, Union[int, float, str]]]

Attributes from all projects

GetAttributesFromCurrentProject() staticmethod

Get the attributes from the current project

Returns:

Type Description
list[tuple[int, Union[int, float, str]]]

Attributes from the current project