Skip to content

Preview Symbol Builder

Class full path: NemAll_Python_IFW_Input.PreviewSymbolBuilder

Implementation of the preview symbol builder

Functions

ArrowSymbol overload

ArrowSymbol(pnt, bDrawIso, viewProj, colorVariant, widthVariant, rotationAngle, allWindows=True) staticmethod

Create an arrow symbol

Parameters:

Name Type Description Default
pnt Point3D

Arrowhead point

required
bDrawIso bool

Draw the arrow symbol inside the isometric view: true/false

required
viewProj ViewWorldProjection

View world projection data

required
colorVariant ARGB

Color of the preview

required
widthVariant int

Width of the symbol

required
rotationAngle float

Rotation angle of the rectangle

required
allWindows bool

Show symbol in all windows

True
ArrowSymbol(pnt, bDrawIso, viewProj, colorVariant, rotationAngle, allWindows=True) staticmethod

Create a small arrow symbol

Parameters:

Name Type Description Default
pnt Point3D

Arrowhead point

required
bDrawIso bool

Draw the arrow symbol inside the isometric view: true/false

required
viewProj ViewWorldProjection

View world projection data

required
colorVariant ARGB

Color of the preview

required
rotationAngle float

Rotation angle of the rectangle

required
allWindows bool

Show symbol in all windows

True

Circle3DSymbol(refPnt, circle, viewProj, colorVariant, linePattern, lineWidth) staticmethod

Create a 3D circle symbol preview

Parameters:

Name Type Description Default
refPnt Point3D

Reference point

required
circle Arc3D

3D circle

required
viewProj ViewWorldProjection

View world projection data

required
colorVariant ARGB

Color of the preview

required
linePattern int

Line pattern

required
lineWidth float

Width of the line

required

CircleSymbol(pnt, bDrawIso, viewProj, colorVariant, radius) staticmethod

Create a circle symbol

Parameters:

Name Type Description Default
pnt Point3D

Center point

required
bDrawIso bool

Draw the circle symbol inside the isometric view: true/false

required
viewProj ViewWorldProjection

View world projection data

required
colorVariant ARGB

Color of the preview

required
radius int

Radius of the circle in pixel

required

CoordCrossSymbol overload

CoordCrossSymbol(plane, armLength, viewProj) staticmethod

Draw the coordinate cross symbol

Parameters:

Name Type Description Default
plane Plane3D

Plane

required
armLength int

Length of the symbol arms

required
viewProj ViewWorldProjection

View world projection

required
CoordCrossSymbol(axisPlacement, armLength, viewProj) staticmethod

Draw the coordinate cross symbol

Parameters:

Name Type Description Default
axisPlacement AxisPlacement3D

Axis placement

required
armLength int

Length of the symbol arms

required
viewProj ViewWorldProjection

View world projection

required

CrossSymbol(pnt, bDrawIso, viewProj, colorVariant, widthVariant) staticmethod

Create a cross symbol

Parameters:

Name Type Description Default
pnt Point3D

Cross center point

required
bDrawIso bool

Draw the cross symbol inside the isometric view: true/false

required
viewProj ViewWorldProjection

View world projection data

required
colorVariant ARGB

Color of the preview

required
widthVariant int

Width of the symbol

required

FilledRectangleSymbol(pnt, bDrawIso, viewProj, colorVariant, widthVariant, rotationAngle) staticmethod

Create a filled rectangle symbol

Parameters:

Name Type Description Default
pnt Point3D

Rectangle center point

required
bDrawIso bool

Draw the rectangle symbol inside the isometric view: true/false

required
viewProj ViewWorldProjection

View world projection data

required
colorVariant ARGB

Color of the preview

required
widthVariant int

Width of the symbol

required
rotationAngle float

Rotation angle of the rectangle

required

Line3DSymbol(refPnt, line, viewProj, colorVariant, linePattern, lineWidth) staticmethod

Create a 3D line symbol preview

Parameters:

Name Type Description Default
refPnt Point3D

Reference point

required
line Line3D

3D line

required
viewProj ViewWorldProjection

View world projection data

required
colorVariant ARGB

Color of the preview

required
linePattern int

Line pattern

required
lineWidth int

Line width

required

LocalCoordinateSystem(coordSystemMatrix, flags, maxSize) staticmethod

Create a symbol for a local coordinate system

Parameters:

Name Type Description Default
coordSystemMatrix Matrix3D

Matrix of the coordinate system

required
flags LCS_Flags

Coordinate system flags

required
maxSize float

Max size of the coordinate system

required

MarkSymbol(pnt, bDrawIso, viewProj, colorVariant, widthVariant) staticmethod

Create a mark symbol (drawn an x)

Parameters:

Name Type Description Default
pnt Point3D

Mark center point

required
bDrawIso bool

Draw the mark symbol inside the isometric view: true/false

required
viewProj ViewWorldProjection

View world projection data

required
colorVariant ARGB

Color of the preview

required
widthVariant int

Width of the symbol

required

OffsetPointSymbols(refPnt, offPnt, bDrawIso, viewProj, colorVariant, widthVariant, refPntAngle, offPntAngle) staticmethod

Create the symbols for an offset point

Parameters:

Name Type Description Default
refPnt Point3D

Reference point

required
offPnt Point3D

Offset point

required
bDrawIso bool

Draw the arrow symbol inside the isometric view: true/false

required
viewProj ViewWorldProjection

View world projection data

required
colorVariant ARGB

Color of the preview

required
widthVariant int

Width of the symbol

required
refPntAngle float

Angle at the reference point

required
offPntAngle float

Angle at the offset point

required

OrthogonalSymbol(pnt, bDrawIso, viewProj, colorVariant, widthVariant) staticmethod

Create an orthogonal symbol

Parameters:

Name Type Description Default
pnt Point3D

Center point

required
bDrawIso bool

Draw the circle symbol inside the isometric view: true/false

required
viewProj ViewWorldProjection

View world projection data

required
colorVariant ARGB

Color of the preview

required
widthVariant int

Width of the symbol

required

ParallelSymbol(pnt, bDrawIso, viewProj, colorVariant, widthVariant) staticmethod

Create a parallel symbol

Parameters:

Name Type Description Default
pnt Point3D

Center point

required
bDrawIso bool

Draw the circle symbol inside the isometric view: true/false

required
viewProj ViewWorldProjection

View world projection data

required
colorVariant ARGB

Color of the preview

required
widthVariant int

Width of the symbol

required

Polyline2DSymbol(refPnt, polyline, viewProj, colorVariant, linePattern) staticmethod

Create a 2D polyline symbol preview

Parameters:

Name Type Description Default
refPnt Point3D

Reference point

required
polyline Polyline2D

Polyline

required
viewProj ViewWorldProjection

View world projection

required
colorVariant ARGB

Color of the preview

required
linePattern int

Line pattern

required

Polyline3DSymbol overload

Polyline3DSymbol(polyline, viewProj, colorVariant, linePattern) staticmethod

Create a 3D polyline symbol preview

Parameters:

Name Type Description Default
polyline Polyline3D

3D Polyline

required
viewProj ViewWorldProjection

View world projection data

required
colorVariant ARGB

Color of the preview

required
linePattern int

Line pattern

required
Polyline3DSymbol(refPnt, polyline, viewProj, colorVariant, linePattern) staticmethod

Create a 3D polyline symbol preview

Parameters:

Name Type Description Default
refPnt Point3D

Reference point

required
polyline Polyline3D

Polyline

required
viewProj ViewWorldProjection

View world projection

required
colorVariant ARGB

Color of the preview

required
linePattern int

Line pattern

required

TrackLine(line, bDrawIso, viewProj, colorVariant, trackLineType) staticmethod

Create a track line

Parameters:

Name Type Description Default
line Line3D

Track line

required
bDrawIso bool

Draw the circle symbol inside the isometric view: true/false

required
viewProj ViewWorldProjection

View world projection data

required
colorVariant ARGB

Color of the preview

required
trackLineType eTrackLineType

Type of the track line

required

TrackMarkSymbol(pnt, bDrawIso, viewProj, colorVariant, widthVariant) staticmethod

Create a track mark symbol

Parameters:

Name Type Description Default
pnt Point3D

Center point

required
bDrawIso bool

Draw the circle symbol inside the isometric view: true/false

required
viewProj ViewWorldProjection

View world projection data

required
colorVariant ARGB

Color of the preview

required
widthVariant int

Width of the symbol

required