Skip to content

Attribute Date

Class full path: NemAll_Python_BaseElements.AttributeDate

Bases: Attribute

Date attribute

Attributes

Day: int property writable

Get the day value

Month: int property writable

Get the month value

Year: int property writable

Get the year value

Functions

__eq__(element)

Equal operator

Parameters:

Name Type Description Default
element AttributeDate

Element to compare

required

Returns:

Type Description
bool

Elements are equal: true/false

__init__ overload

__init__()

Initialize

__init__(id, day, month, year)

Constructor

Parameters:

Name Type Description Default
id int

Attribute id

required
day int

Day

required
month int

Month

required
year int

Year

required
__init__(element)

Copy constructor

Parameters:

Name Type Description Default
element AttributeDate

Element to copy

required

__ne__(element)

Unequal operator

Parameters:

Name Type Description Default
element AttributeDate

Element to compare

required

Returns:

Type Description
bool

Elements are unequal: true/false

__repr__()

Convert to string