Skip to content

Bitmap Area Properties

Class full path: NemAll_Python_BasisElements.BitmapAreaProperties

BitmapAreaProperties class

Attributes

BitmapName: None property

Property for bitmap name of the bitmap area

:type: None

DirectionToReferenceLine: None property

Property for direction to reference line

:type: None

ReferencePoint: None property

Property for reference point

:type: None

RotationAngle: None property

Property for rotation angle

:type: None

TransparentColor: None property

Property for transparent color

:type: None

TransparentColorTolerance: None property

Property for transparent color tolerance

:type: None

UseDirectionToReferenceLine: None property

Property for usage of direction to reference line

:type: None

UseMetricalValues: None property

Property for metrical values

:type: None

UsePixelMask: None property

Property for usage of mask black pixels

:type: None

UseReferencePoint: None property

Property for usage of reference point

:type: None

UseRepeatTile: None property

Property for repeat tile

:type: None

XOffset: None property

Property for X offset value

:type: None

XScalingFactor: None property

Property for X scaling factor

:type: None

YOffset: None property

Property for Y offset value

:type: None

YScalingFactor: None property

Property for Y scaling factor

:type: None

Functions

__eq__(prop)

equal operator

Parameters:

Name Type Description Default
prop BitmapAreaProperties

BitmapProperties to compare

required

Returns:

Type Description
bool

true if they are equal, false otherwise

__init__()

Initialize

__repr__()

Convert the list to a string

Returns:

Type Description
str

List values as string