Skip to content

Transition Type

Class full path: NemAll_Python_BasisElements.TransitionType

Bases: IntEnum

Transition types of the filling property

Attributes

eNoTransition = 0 class-attribute instance-attribute

eOneColorTransition = 1 class-attribute instance-attribute

eTwoColorTransition = 2 class-attribute instance-attribute

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
TransitionType

value for the key