Skip to content

Bar Area Placement Properties

Class full path: NemAll_Python_Reinforcement.BarAreaPlacementProperties

Classes

Benching

Bases: IntEnum

Benching type

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
Benching

value for the key

PlacementStrategy

Bases: IntEnum

PlacementStrategy type

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
PlacementStrategy

value for the key

Functions

__init__ overload

__init__()

Initialize

__init__(diameter, distance, overlapping, isMoveOverlapping, maxBarLength, startBarLength, maxPlacementLength, firstBarEdgeDistance, placementStrategy, benching, benchingLength, isPolygonalPlacement)

Constructor

Parameters:

Name Type Description Default
diameter float

Diameter

required
distance float

Distance

required
overlapping float

Overlapping

required
isMoveOverlapping bool

Is overlapping moved: true/false

required
maxBarLength float

Maximal bar length

required
startBarLength float

Start bar length

required
maxPlacementLength float

Maximal placement length, 0 = will be calculated

required
firstBarEdgeDistance float

First bar edge distance, <0 = will be calculated

required
placementStrategy PlacementStrategy

Placement strategy

required
benching Benching

Benching

required
benchingLength float

Benching length

required
isPolygonalPlacement bool

Place in polygon: true / place per meter: false

required