Skip to content

Section Along Path Filter Properties

Class full path: NemAll_Python_BasisElements.SectionAlongPathFilterProperties

Filter properties

Attributes

DrawingFilesProperties: SectionDrawingFilesProperties property writable

Access drawing file params

Get the SectionDrawingFilesProperties

IsAssociativityOn: bool property writable

Get the When the section is frozen / associativity is OFF -, no updates are available for it

IsSelectionFilterOn: bool property writable

Get the when == true - only selected elements are included to UVS model / when == false (default value) - selected elements are excluded from UVS model

LayerProperties: SectionLayerProperties property writable

Access layer params

Get the SectionLayerProperties

Functions

__init__ overload

__init__(bInitFromSTW=False)

constructor

Parameters:

Name Type Description Default
bInitFromSTW bool
  • is structure initialized from standard values
False
__init__(B)

copy constructor

Parameters:

Name Type Description Default
B SectionAlongPathFilterProperties
  • object to copy
required