Skip to content

Functions of the module Precast

Module full path: NemAll_Python_Precast

Exposed classes and functions from NemAll_Python_Precast

CreatePrecastElements(doc, insertionMat, elements, modelEleList, modelUuidList, viewProj, delete_python)

Create the precast elements

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required
insertionMat Matrix3D

Insertion matrix

required
elements BaseElementAdapterList

List of created elements

required
modelEleList list

List of model elements which have to be created

required
modelUuidList list

List with the model UUIDS in modification mode

required
viewProj ViewWorldProjection

View projection

required
delete_python bool

bool weather the python should be deleted after update

required

LockPrecastUpdate()

Lock the precast update

TriggerPrecastUpdate(elements)

Trigger the precast update

Parameters:

Name Type Description Default
elements BaseElementAdapterList

Elements to update

required

Returns:

Type Description
bool

update successful: true/false)

UnlockPrecastUpdate()

Lock the precast update