Skip to content

Spiral Element

Class full path: NemAll_Python_Reinforcement.SpiralElement

Bases: ReinfElement, AllplanElement

Functions

SetLengthFactor(arg2)

Get the length factor

Returns:

Type Description

Length factor

SetNumberLoopsEnd(arg2)

Set the loops at the end

SetNumberLoopsStart(arg2)

Set the loops at the start

SetPitchSections(pitch1, length1, pitch2, length2, pitch3, length3, pitch4, length4)

Set the pitch section

Parameters:

Name Type Description Default
pitch1 float

Pitch section 1

required
length1 float

Length section 1

required
pitch2 float

Pitch section 2

required
length2 float

Length section 2

required
pitch3 float

Pitch section 3

required
length3 float

Length section 3

required
pitch4 float

Pitch section 4

required
length4 float

Length section 4

required

SetPlacePerLinearMeter(bPlacePerMeter)

Set the place per linear meter state

Parameters:

Name Type Description Default
bPlacePerMeter bool

Place per linear meter: true/false

required

__init__ overload

__init__()

Initialize

__init__(positionNumber, diameter, steelGrade, concreteGrade, rotationAxis, contourPoints, pitch, hookLengthStart, hookAngleStart, hookLengthEnd, hookAngleEnd, concreteCoverStart, concreteCoverEnd, concreteCoverContour)

Constructor

Parameters:

Name Type Description Default
positionNumber int

Position number

required
diameter float

Diameter

required
steelGrade int

Steel grade

required
concreteGrade int

Concrete grade

required
rotationAxis Line3D

Rotation axis

required
contourPoints Polyline3D

Contour points

required
pitch float

Pitch

required
hookLengthStart float

Hook length at the start

required
hookAngleStart float

Hook angle at the start

required
hookLengthEnd float

Hook length at the end

required
hookAngleEnd float

Hook angle at the end

required
concreteCoverStart float

Concrete cover at the start

required
concreteCoverEnd float

Concrete cover at the end

required
concreteCoverEnd float

Concrete cover at the contour

required